Portfolio Online | Browser requirements

Browser requirements

You can access Portfolio Online via an internet connection using one of the following browser versions:

  • Microsoft Internet Explorer 7
  • Microsoft Internet Explorer 8
  • Microsoft Internet Explorer 9
  • Mozilla Firefox 6
  • Mozilla Firefox 7

Please note: Portfolio Online may not work properly with older browser versions.

What browser am I using?

To check which browser you currently have installed, go to the "help" menu on your browser and select the " About (browser name)" menu item. A new page will appear with the version number (and other browser information).